www.supertalent.com The Official Super Talent Support Forum

Login
FAQ MembersRegister

Require permission to flash firmware for FTM64GX25H

The latest and final firmware for Ultra Drive GX/GX2 series.

Require permission to flash firmware for FTM64GX25H

Postby effdschie » Sat Dec 29, 2012 4:39 am

Hello James,

SSD Model number: FTM64GX25H, firmware 2030
Serial number: P595418-TFBX-B069212 (STT_FTM64G225H)
The system is: Mainboard ASROCK ALiveNF6G-DVI with Athlon64X2, 3GB RAM, Onboard-VGA, Windows 8 Pro 64bit,...
The SSD is the only harddrive and connected to the SATA1 port.
I have right now used your "Windows SSD ID Checker" with this system. But it does not give information to my SSD, nothing was detected. CrystalDiskInfo v5.2.0 did it. And it stated a health status of 57%.

I would like to know whether I should update it. I have also access to another PC (Core 2 Duo, ASUS P5B Deluxe, SSD Samsung 840 Pro, ...) if required.

Moreover I have seen the NAND-cleaner. Is it recommended to use it as well, if yes which one? My SSD is equipped with the switch accessible without opening the SSD case.

Thanks
Frank
effdschie
 
Posts: 1
Joined: Sat Dec 29, 2012 3:42 am

Postby SSD-James » Mon Dec 31, 2012 8:50 am

It is better to use your P5B PC.

First go to the following site and download the 1st file.
viewtopic.php?f=74&t=10867
Then, copy that file on to the P5B OS drive, which is Samsung 840...
Read the instruction file carefully.
Run it on the SSD 840.

SSD Model number: FTM64GX25H, firmware 2030
Serial number: P595418-TFBX-B069212 (STT_FTM64G225H)
Your SSD Flash selection is TH58NVG5D1DTG20 64GB.

Thanks,
James
SSD-James
 
Posts: 2076
Joined: Fri Jul 16, 2010 12:41 pm

Postby jeanj » Sun Jan 20, 2013 6:41 am

hi James,

which flash mode to use with a

STT_FTM64GX25H
P590946-ATBX-9269307
(Gigabyte EP-45-UD3R)

thanks

Jean
jeanj
 
Posts: 6
Joined: Sun Jan 20, 2013 6:33 am

Postby SSD-James » Tue Jan 22, 2013 1:26 pm

It is K9LBG08U0M 64GB.
SSD-James
 
Posts: 2076
Joined: Fri Jul 16, 2010 12:41 pm

Postby jeanj » Sun Feb 03, 2013 6:27 am

James, thanks for the info. Nevertheless, I have problems with the update ...

SSD is connected to a connector 1-4, using win7 64, UAC is diabled, SDD is powered and connected with cable, mptool is started with admin rights, I enter the infos ... but after pressing refresh, the SSD doesn't show up in the list ...

Any hints what to try?

tschau

Jean
jeanj
 
Posts: 6
Joined: Sun Jan 20, 2013 6:33 am

Postby SSD-James » Wed Feb 06, 2013 11:10 am

Did you set it as "Factory mode"?
SSD-James
 
Posts: 2076
Joined: Fri Jul 16, 2010 12:41 pm

Postby jeanj » Thu Feb 07, 2013 2:53 am

yes, of course, and I tried both modes and different connectors several times ...
jeanj
 
Posts: 6
Joined: Sun Jan 20, 2013 6:33 am

Postby SSD-James » Thu Feb 07, 2013 10:05 am

Is your MB gigabyte BIOS set as AHCI mode?
What hard drive did you use for Win7-64 OS?
SSD-James
 
Posts: 2076
Joined: Fri Jul 16, 2010 12:41 pm

Postby jeanj » Fri Feb 08, 2013 3:52 am

yes, everything is done as mentioned in the manual, using AHCI mode (Intel ICH10 / MSAHCI), my main drive running win7-64 is another SSD, a Samsung 830 ...
jeanj
 
Posts: 6
Joined: Sun Jan 20, 2013 6:33 am

Postby SSD-James » Fri Feb 08, 2013 10:23 am

It looks like some unverifiable error on your SSD.
Please RMA it.
SSD-James
 
Posts: 2076
Joined: Fri Jul 16, 2010 12:41 pm

Next

Return to Latest Firmware MP TOOL Download

Who is online

Users browsing this forum: No registered users and 1 guest