Page 2 of 4

PostPosted: Thu Nov 22, 2012 6:10 am
by growbag
About to try flashing firmware for a Super Talent 128GB FTM28GX25H drive.

I believe the serial number is: P661757-MJBY-B22A017 (although that last "0" could be an "O", I have no way of telling!). I get that number from the bar coded sticker on the drive itself, as I can't seem to find a way of reading the serial number electronically (I searched on this forum but can't understand it, sorry).

I've downloaded both the ISO and the EXE versions of the firmware update tool, and read all the PDFs, but it's really not clear if I should run the update tool from the SSD, or if I need to boot from a second drive in order to update the SSD.

My laptop in a Dell Alienware M17x, Intel i7 CPU, and ATI video card, but I have no idea which chipset it uses.

Thanks.

===================================================================================

EDIT: My laptop will not even boot once I switch that switch on the SSD! It just sits at BIOS screen with the HDD eyes glowing, so how can I update the firmware?

===================================================================================

EDIT2: OK, after pissing around for many many hours I finally managed to get it to detect the SSD. Here's what I did (in plain English and simple steps!) if it helps anyone else in the future -


1. Download the (non-iso) update tool from here - http://supertalent.com/home/forum/download/file.php?id=182, extract it, install it, and read the file "MP TOOL Guide.pdf". The rest are just confusing and don't help in any way at all, so forget them! Print tht file out if you can as you will need to reference it later, so keep a copy on hand.

2. Backup ALL your data.

3. Write down the Model number & serial numbers of the drive. The exact model number can be gotten through device manager, but not the serial number. The S/N is on the white barcoded label on the drive and has the format xxxxxxx-XXXX-xxxxxxx, ie mine is P661757-MJBY-B22A017.

3. You will need a second hard disk with a working copy of Windows to boot from. Set it as your primary HDD.

4. On the Dell Alienware M17x there is NO NEED to change the SATA mode in BIOS to ATA mode, I left mine set at AHCI mode (if I changed it manually, then it refused to boot, and after 10 minutes it would re-set the BIOS automatically to AHCI mode anyway!). If you have yours set to RAID mode then you might have to first change it to AHCI mode, then re-install Windows.

5. Remove the SSD from the laptop, but leave the bottom open as you will need to hot-swap the drive in later! Also, leave that black converter connector thing in the laptop, just remove the drive itself. SATA connectors are designed specially with the power pins shorter than the data pins, so that when you plug the drive in, the data pins connect first, and lastly the power pins connect. If you try to plug the converter straight in, it could do some serious damage. If you can't understand what I mean, ask nicely and I'll take pics and put them up for you.

6. Turn the laptop on and wait till Windows finishes messing about.

7. In Control Panel, search for "accout control" and set it to minimum (ie "Don't ask").

8. Run the MP Tool, set the switch on the SSD to the outside position (away from the connectors), and carefully turn the laptop over so you can slip the SSD into the 2nd slot, and slide it in. Be extremely careful as you could do some serious damage here, and also scratch your laptop. You should see a red light near the switch on the SSD, this indicates that it is now in "Factory" (flash) mode. You might have to wait for Windows to install a device driver for the new mode of the SSD, it reports it as a "Pang Dong raw mode" something or other, sorry I can't remember exactly.

9. Follow the instructions given in "MP TOOL Guide.pdf", and if all went well you should be updated.

I guessed my SSD Flash selection was "MT29F64G08CFABA 128GB", as James had given that number to 2 people already that have a similar set of middle serial numbers as me, and so far it seems to have worked. I should have waited for an answer from James, but I really couldn't wait for possibly days for an answer. When I check my drive info in Device Manager, it now shows firmware as ver 2142, whereas earlier it was 2030, so I guess it worked. Hopefully James will still drop in and confirm my number anyway, as it would be nice to be 100% sure that I flashed it properly ;).

Good luck.

PostPosted: Fri Nov 23, 2012 11:50 am
by SSD-James
You properly did the FW updating with MP TOOL file. (exe file)
You also selected the correct flash selection.
I had a series of problem to open the website of Dell/Alienware laptop... So...

ISO file solution sometimes works... Not everytime.
That was why I released MP TOOL solution.

Thanks,
James

PostPosted: Thu Nov 29, 2012 5:17 am
by strom
hi
After severe troubles I need to flash the ssd FTM28gx25h sw 2030 serial P662314-MJBY-B29A025
on a Intel H67 board (Dell Vostro 460)

Surfed through the whole forums an ended up here, hope you can help me howto...

Thx and greetings

PostPosted: Mon Dec 10, 2012 11:36 am
by SSD-James
FTM28gx25h sw 2030 serial P662314-MJBY-B29A025

Your SSD Flash selection is MT29F64G08CFABA 128GB.
Please refer to the following site.
viewtopic.php?f=74&t=10867

Download the 1st file and read the instruction and follow the direction.

Thanks,
James

PostPosted: Fri Dec 28, 2012 10:59 am
by de1987
Hi James ,

i am with a problem in my SSD, many times it get BSODs, i never flashed before
can i flash? what flash selection?

Model number: FTM28GX25H
Serial number: P654563-MJBY-A12A279
Board : Gigabyte GA-MA78GM-S2H v1

thanks

PostPosted: Fri Dec 28, 2012 11:11 am
by SSD-James
You have AMD board.
Please refer to the following site and follow the direction.
viewtopic.php?f=74&t=10867
Specially 1st and last file downloads are needed.
Your SSD Flash selection is MT29F64G08CFABA 128GB.

PostPosted: Fri Dec 28, 2012 11:21 am
by de1987
question, my OS is in SSD
do i need to install a OS in my HDD to flash it?

PostPosted: Fri Dec 28, 2012 11:29 am
by SSD-James
Yes, please.

Flash FTM28GX25H

PostPosted: Fri Dec 28, 2012 11:30 am
by de1987
never mind, stupid question
i am making backup everything on my ssd, i will use the ISO
can i use, right?

thanks, happy new year

PostPosted: Fri Dec 28, 2012 11:32 am
by SSD-James
If you use the ISO file, it sometimes will not clear the issue and wrong working.
That is why I asked you to use MP TOOL.

Thanks,
James