www.supertalent.com The Official Super Talent Support Forum

Login
FAQ MembersRegister

FTM32GX25H - Working slow then disappear from the system.

Any Indilinx controller base SSD, 2.5" / 1.8" / VSSD / SLIM LITE / Master Drive KX2

FTM32GX25H - Working slow then disappear from the system.

Postby xparanoid » Thu Sep 09, 2010 11:41 pm

Hi,

I have two ssd in raid 0 since one year, and a few weeks ago, my windows installation went bad, and i had to reinstall it.

I took the chance to update their firmwares to 1916 before reinstallation.
But the installation failed in raid0. I blamed my southbridge at that time, and having not enough time to make research, i installed without raid, successfully.

So now, 1 ssd contains windows installation, the other one would contain apps. let's call them "windows ssd" and "app ssd" :)

it worked well until two days ago, when i was installing a pc game. The app ssd became very slow during the installation, windows explorer took a bunch of memory, then intel application said "your hard drive has been disconnected". of course it failed to install the game. I tried a few times without success.

I tried to install on the windows ssd, and it worked. I tried to switch the app ssd sata cables, with no success.

I'm running out of ideas. I can of course do a backup of what's in the ssd, so if you have a "last resort utility" i could use, or other idea, it would be appreciated. (SSD-James, you seem to be the man! :D )

Thanks for your help
xparanoid
 
Posts: 2
Joined: Thu Sep 09, 2010 10:48 pm

Postby SSD-James » Fri Sep 10, 2010 8:23 am

I sent you an e-mail to ask your platform information.
SSD-James
 
Posts: 2076
Joined: Fri Jul 16, 2010 12:41 pm

Postby Da_G » Fri Sep 10, 2010 5:22 pm

Wow! I'm glad i'm not the only one to run into this problem.

In my case it's 4 SSD (Ultradrive GX FTM32GX25H) in RAID0. Originally this configuration ran fine for about the same time (1 year) and then failed in a similar way. I RMA'ed all 4 drives and it worked again fine for 6 months. Then again the problem occured! I replaced all 4 SATA cables to rule that out as an issue, and for a short time the problem appeared to go away. Now it is happening again!

The time between failures is very frequent now however. The symptoms are the same in RAID0 as it would appear as seperate drives (I have ran into the same failure there as well) - first the Array/Drive will start to run very slowly, to the point where if a program attempts to write to the disk it will hang and windows will prompt to close it, then some period of time later it will un-hang and the write will occur.. that will continue for a period of time until the drive disconnects alltogether.

At that point some data has been lost on the drive, when set up as RAID0 the RAID becomes broken and impossible to re-assemble, resulting in the need to re-create the RAID/Format. If the drives are broken out into seperate drives, looking at the raw partition in a hex editor you can see some zeros have been written where data should be. I wonder if this is some problem with the garbage collection function of firmware?

Now that I know i'm not the only one with this problem, Supertalent, is there something that can be done about this? Will another RMA perhaps solve the problem? Right now it is very reproducable for me - I can re-build the RAID0, format the drives, install windows, install a few apps, power off, power back on, and the RAID0 will have been corrupted.

The same ports and cables work fine with hard drives, i'm an experienced technician and at my wits end as to how to deal with this problem!

Motherboard: Abit IP 35 Pro (ICH9R sata chipset using 6 of 6 ports - 4x for SSD 2x for hard drives)
RAM: 8GB DDR2 800mhz
Video Card: GeForce GTX 275 896MB
Power Supply: Antec EarthWatts 550W
Case has excellent cooling and airflow characteristics.
All SSD are running 2030 (problem occured also with 1916, i do NOT remember this happening on firmware without GC, perhaps a coincidence or perhaps GC is partly to blame?)
SSD ID CODE 051302
Da_G
 
Posts: 8
Joined: Thu Jul 09, 2009 8:38 pm

Postby xparanoid » Sun Sep 19, 2010 2:39 am

Hi Da_G,

I got some help via private message from SSD-James, maybe you should contact him, if he hasn't done so yet!
xparanoid
 
Posts: 2
Joined: Thu Sep 09, 2010 10:48 pm

Postby Da_G » Tue Sep 28, 2010 11:18 am

Well, I did get some help so far. Apparently running SSD in RAID is completely unsupported by supertalent due to RAID controller not passing along TRIM properly. (Any RAID controller)

Unfortunately I purchased these 4 SSDs expressly for the purpose of use in RAID0, one usage case example is a backing store for large file manipulation in adobe photoshop. Size of the disks in single drive mode (which is supported by ST) is unfortunately too small for my needs. So I requested to ST to replace the 4x 32GB drives with a single 128GB drive which would work OK (but slower)

Unfortunately the request was denied. So now i'm waiting to hear about a normal RMA proceedure or other method (the disks will lose data even in single drive mode now after about 1-2 days)

I think ST should make it clear that not only is operation in RAID0 detrimental to performance due to lack of TRIM, but that data loss will also occur as a result. Performance degradation is acceptable (I knew about this at the time of purchase), but data loss is not (I had no idea this would occur) - Right now it appears to me as if GC is not functioning properly. Viewing the drives raw sectors using a hex editor after failure, shows random sectors have been erased to all NULL (0x00) - seems to me the only reason for the drive to automatically erase a sector and write NULLs to it is for GC. Seems like it is just not identifying the proper sectors to erase.

Hopefully an acceptable solution can be reached soon as currently the 4 drives are sitting in a box. Using them in any system results in random failures (Drives sometimes disappear from BIOS, or partition table randomly corrupts, filesystem corruption, etc.) - Those same systems are working fine without the SSDs inside. Data loss is experienced on the SSDs within 24 - 48 hours after formatting/running sanitary_erase.exe, and copying some data to them. Obviously they are unusable with data loss occuring so frequently. Really disappointing as the first several months of usage was perfect with no problems, and great performance!
Da_G
 
Posts: 8
Joined: Thu Jul 09, 2009 8:38 pm


Return to UltraDrive GX/GX2

Who is online

Users browsing this forum: No registered users and 1 guest

cron