www.supertalent.com The Official Super Talent Support Forum

Login
FAQ MembersRegister

Ultra Drive "Firmware download Error"

All firmware upgrade issues should go here

Postby Part4U » Thu Dec 29, 2011 9:34 am

Hi There!
My Problem is the same as many others posted:
Tried to Flash FW 2142 over the .iso, anything seemed to be correct, then the "Download Firmware" Error, and after that the System isn`t available to find the Disk. Only the YATODPONG 128 ....

MY System: Asrock Extreme3 R2.0
Win7 Ultimate x64 (UAC deactivated all the Time!)
2x 4GB RAM
All Drives at AHCI

FTM64GX25H
P655233-MJBY-A19A014
S.N. 132789

What can i do to reactivate the Drive? Need it fast in my Laptop again for Work :(
Is there a German Guide for this? I think my English isn麓t good enough for strong technical words .....
Thanks for Help - Part4U
Part4U
 
Posts: 2
Joined: Thu Dec 29, 2011 9:04 am

Postby SSD-James » Thu Dec 29, 2011 3:29 pm

FTM64GX25H P655233-MJBY-A19A014
Your SSD Flash selection is MT29F32G08CBABA 64GB.

Please download the MP TOOL and run it onto your SSD.
You will get your SSD reactivated easily.
The guide will give you the photographic instruction so it must be very easy for you.
viewtopic.php?f=74&t=10867
Download the first file.
Thanks,
James
SSD-James
 
Posts: 2076
Joined: Fri Jul 16, 2010 12:41 pm

Postby Part4U » Mon Jan 02, 2012 12:35 am

THX!! IT WORKS :)

But was a hard way to get it:
In User Mode the System won`t come up .... No detection!
When plugged on in the running system (user Mode) the MPTool and the System weren`able to detect. :oops:
Starting the System with Factory Mode, BIOS recognized the SSD, but the OS hang up shortly after Start. :evil:
So the only Way was to plug the (Factory Mode) SSD at a complete loaded OS. Then i was able to Flash the Firmware. After that, i started the System in User Mode (SSD was detected as "YATAPDONG ..." and did the FW Update again!
Now the SSD is running again! :P

THX again and all a happy New Year - Part4U :mrgreen:
Part4U
 
Posts: 2
Joined: Thu Dec 29, 2011 9:04 am

Postby SSD-James » Mon Jan 02, 2012 5:20 pm

Yup, that is the way.
Your PC was not booting becuase you did not change the Boot Priority.

Thanks,
James
SSD-James
 
Posts: 2076
Joined: Fri Jul 16, 2010 12:41 pm

Postby Terabyte » Sun Jan 15, 2012 2:42 am

Hello

I have the same problem here.
When I use FW Updater 2142.iso, I get Firmware download Error...

Product: FTM64GX25H
The Serial of my SSD: P675552-MJJV-228B085
Terabyte
 
Posts: 2
Joined: Sun Jan 15, 2012 2:36 am

Postby SSD-James » Mon Jan 16, 2012 10:49 am

Product: FTM64GX25H
The Serial of my SSD: P675552-MJJV-228B085

Please use MP TOOL.
Flash selection is MT29F32G08CBABA 64GB.
SSD-James
 
Posts: 2076
Joined: Fri Jul 16, 2010 12:41 pm

Postby Terabyte » Sun Jan 22, 2012 1:52 am

Will I loose my data on the ssd when I make the Firmware update with the MP-Tool?
Terabyte
 
Posts: 2
Joined: Sun Jan 15, 2012 2:36 am

Postby SSD-James » Mon Jan 23, 2012 8:29 am

Yes, you will lose whole data. Please back up.

Thanks,
James
SSD-James
 
Posts: 2076
Joined: Fri Jul 16, 2010 12:41 pm

Postby thefitzzz » Sun Jun 24, 2012 9:13 am

Hi there,

maybe a little late, but I need the flash info for:

STT_FTM28GX25H
P611623-MIBY-204A016

Autodetect failed for me.

Thanks a lot!
thefitzzz
 
Posts: 1
Joined: Sun Jun 24, 2012 9:10 am

Postby SSD-James » Tue Jun 26, 2012 8:54 am

STT_FTM28GX25H
P611623-MIBY-204A016
It is MT29F64G08CFABA 128GB.
SSD-James
 
Posts: 2076
Joined: Fri Jul 16, 2010 12:41 pm

PreviousNext

Return to Firmware

Who is online

Users browsing this forum: No registered users and 1 guest

cron