www.supertalent.com The Official Super Talent Support Forum

Login
FAQ MembersRegister

Ultra Drive "Firmware download Error"

All firmware upgrade issues should go here

Postby phil » Tue Aug 31, 2010 3:12 am

Hi,
I've got a "firmware dowload error" message too.
My ssd is an ultradrive FTM64GX25H. Trying to upgrade 1819 to 2030.

Has anyone an idea?

@James: I send you a pm with my s/n etc.

Thanks a lot!

Best Regards

Phil
phil
 
Posts: 1
Joined: Mon Aug 30, 2010 11:36 pm

Postby isk » Thu Feb 17, 2011 5:54 am

Hi,

I've got exactly the same problem on my FTM28GX25H, I've tried to send a PM to SSD-James which unfortunately was met with the following error HTTP Error 500 (Internal Server Error).
Afterwards I've tried to send an email to your support address which came back with the following error Server error: '550 5.1.1 <support@supertalent.com> relaying denied'.

Please send me a pm or an email with a way to relay my SSD's information to you so that you can send me the tool to repair it.

Thanks in advance and best regards,

isk
isk
 
Posts: 1
Joined: Tue Feb 15, 2011 6:36 am

Postby Target2003 » Thu Feb 17, 2011 8:06 am

isk wrote:Hi,

I've got exactly the same problem on my FTM28GX25H, I've tried to send a PM to SSD-James which unfortunately was met with the following error HTTP Error 500 (Internal Server Error).
Afterwards I've tried to send an email to your support address which came back with the following error Server error: '550 5.1.1 <support@supertalent.com> relaying denied'.

Please send me a pm or an email with a way to relay my SSD's information to you so that you can send me the tool to repair it.

Thanks in advance and best regards,

isk


i have a similar problem with my two FTM64GX25H
Target2003
 
Posts: 4
Joined: Tue Feb 15, 2011 3:04 am

Postby SSD-James » Tue Feb 22, 2011 9:03 am

Your issue was solved at the other topic.
Let me know if it is different.
SSD-James
 
Posts: 2076
Joined: Fri Jul 16, 2010 12:41 pm

Postby YBS1 » Mon Feb 28, 2011 5:30 pm

I've received the "firmware download error" message as well.
I have an FTM28GX25H and was upgrading from 1916 to 2030. Unfortunately this bricked the drive, if I move the switch to factory mode it can be detected as "YATAPDONG BAREFOOT-ROM ATA Device" but hangs the system in normal operation mode.
YBS1
 
Posts: 2
Joined: Sat Feb 26, 2011 10:51 pm

Postby SSD-James » Mon Feb 28, 2011 5:51 pm

Please give me your product model serial number like xxxxxxxxx-XXXX-xxxxxxxx
SSD-James
 
Posts: 2076
Joined: Fri Jul 16, 2010 12:41 pm

Postby YBS1 » Mon Feb 28, 2011 6:12 pm

P607517-MIBY-116A013
YBS1
 
Posts: 2
Joined: Sat Feb 26, 2011 10:51 pm

Postby SSD-James » Tue Mar 01, 2011 10:49 am

OK. Got it.
SSD-James
 
Posts: 2076
Joined: Fri Jul 16, 2010 12:41 pm

Postby M-A-X » Sun Jun 26, 2011 4:52 am

I got the same problem now (not shown at USER mode, detected at Factory mode)
I have a STT_FTM28GX25H with the s/n P609740-MIBY-125A001
Firmware is 1916 and i tried and update it to 2142 (with the Nvidia Chipset method)

EDIT:
Finally i got it. I dont know what did the trick but here are 2 things i did just before it worked^^
1. I turned of UAC (msconfig -> UAC -> put switch all to the bottom)
2. (and that you should really put in your guide!!!) start MPtool as ADMIN! (till now i always just startet it as normal user)
M-A-X
 
Posts: 3
Joined: Sun Jun 26, 2011 4:48 am

Postby SSD-James » Mon Jun 27, 2011 8:32 am

Yup,
I actually mentioned it clearly on the original MP TOOL and updater.
But I forgot to say that on the NVIDIA/AMD user guide.

Thanks,
SSD-James
 
Posts: 2076
Joined: Fri Jul 16, 2010 12:41 pm

PreviousNext

Return to Firmware

Who is online

Users browsing this forum: No registered users and 1 guest

cron