www.supertalent.com The Official Super Talent Support Forum

Login
FAQ MembersRegister

Firmware V1819-revised 10-19-09

All firmware upgrade issues should go here

Re: Firmware V1819

Postby tody » Sat Oct 17, 2009 8:15 pm

ST-J wrote:Hi tody:
Did you flash it back to V1571 before update to V1819? Check the bios setting, also, please record the message you get while you attempt to install w7.


Hi ST-J
schniff no i updatet from 1711.
I check the bios settings its ok
When i install W7
1 attempt: the W7 install go to ~20 % then write error
2 attempt: the W7 install blocks off with message ~ The HD ist noch bootable in the bios

Cu Heinrich
tody
 
Posts: 7
Joined: Thu Sep 03, 2009 3:09 am

Re: Firmware V1819

Postby Macreiter » Sat Oct 17, 2009 10:14 pm

Kann es sein, das eine SSD mit der V1819 jetzt ein wenig langsamer ist?
Und was wurde bei dieser Firmware Version verbessert?

Could it be that an SSD with the V1819 is now a little slower?
And what has been improved in this firmware version?
Macreiter
 
Posts: 7
Joined: Thu Jul 16, 2009 9:16 pm

Re: Firmware V1819

Postby coke » Sat Oct 17, 2009 11:26 pm

hello

FTM32GX25H sn CBIX ,under 1571

error in ide and ahci ,under windows xp and boot cd rom ...


[ERROR] pci bios not found
not found any drive .....


any idea????
coke
 
Posts: 8
Joined: Wed Sep 16, 2009 3:48 am

Re: Firmware V1819

Postby nirolf » Sun Oct 18, 2009 1:36 am

ST-J wrote:
nirolf wrote:I have the a FTM32GX25H - ABIX SSD with firmware 1275. Can I go directly to 1819?

To be honestly, i did not try it, when we release V1571, some ppl upgrade it from V1275 without any problem.
I don't have V1275 drive with me, if you find any problem to flash it directly from V1275 to V1819, PM me and I will email you the old version.


Thanks for the answer. I tried to go directly from v1275 -> v1819 but it didn't work.

[Error] Vendor information fail
[Error] Firmware customer type read fail
Invalid SSD!

So I updated to v1571 using the tool on the support page, then to v1819. All went well, no data loss also.

I would like to add that since I don't have an optical drive in this PC I used an USB stick (made with UltraISO). So no BANANA issues for me, maybe those that have this problem should try it this way.

One more question though, is it safe to use the wiper tool with v1819? I think TRIM it's not working because I have an nVidia chipset.
nirolf
 
Posts: 3
Joined: Fri Oct 16, 2009 11:47 am

Re: Firmware V1819

Postby odirex » Sun Oct 18, 2009 4:10 am

Any help is greatly appreciated:

My 64gb drive has a BEBX serial. I had no problem downgrading firmware from 1711 to 1571. I tried launching the 1819 update via many different boot/live discs and bios settings, always with the same result. In dos, I can see my C drive partition and browse the files, but the 1819 tool tells me 'no drive found'.

I have 2 computers, a desktop and a laptop. I've tried connecting the drive to both. Same result on both. Neither machine has a raid setup. Also, neither bios has any setting for "AHCI Mode" anywhere. There are no options to set the drive to IDE mode or disable S.M.A.R.T.

This would be much easier if the update tool didn't require 'PCI Bios' mode. That way I could connect the drive through an external Sata-USB adapter and flash the firmware from within windows. Any suggestions?
odirex
 
Posts: 3
Joined: Sun Oct 18, 2009 3:54 am

Re: Firmware V1819

Postby uwe68 » Sun Oct 18, 2009 11:25 pm

Why upgrading to 1819 when 1571 is running well? There楹搒 absolutely no reason for that!! With 1819, performance decreases and trim doesn楹搕 work also!! Just another BETA!!!!
uwe68
 
Posts: 4
Joined: Fri Jun 05, 2009 7:14 am

Re: Firmware V1819

Postby khalis » Mon Oct 19, 2009 1:53 am

Hello everyone :)

The flash from v1571 from v1819 has worked with succes full :)
Before I was with the fw v1711 and I have downgraded to v1571 before to flash to v1819. ;)

Everything is fine and I got back the own ssd performance before I flash to v1711. 8-)


Edit : I've just test again with atto and today i got a low write no same as yesterday :x
I'll do an hdderase again and check ti again. :ugeek:
Last edited by khalis on Mon Oct 19, 2009 7:52 am, edited 1 time in total.
SSD SuperTalent FTM28GX25H 128Go ME
khalis
 
Posts: 15
Joined: Sat May 30, 2009 1:25 am

Re: Firmware V1819

Postby Johnny Ego » Mon Oct 19, 2009 3:57 am

hi,
i'va downgraded my 64Gb SSD Ultradrive GX from 1711 to 1571 some weeks ago when i buy it.
It's an FTM64GX25H with DEBX in the serial.

Today i've updated to 1819 using a dos pendrive in IDE mode and the process was very fast and with no problem.
All my data were ok and 'ive booted my win 7 x64 in AHCI and then i've set disabledeletenotify to 0.
I've tried to run a session of AS SSD Benchmark and'ive noticed an high drop of performance in the 4k write test from 7 Mb/s with the 1517 to 4,5 Mb/s with 1819 and the Access was doubled!

It's normal with this FW?
How i can refresh the performance if it's not the FW?
I can use the 1517 PRT or the 1711?

I've done a backup before the update so now i'm reinstalling win 7 x64 with a fast format performed by the w7 install disk to see if i get the original performances. Is this correct?
Johnny Ego
 
Posts: 2
Joined: Mon Oct 19, 2009 3:45 am

Re: Firmware V1819

Postby khalis » Mon Oct 19, 2009 7:41 am

Johnny Ego wrote:hi,
i'va downgraded my 64Gb SSD Ultradrive GX from 1711 to 1571 some weeks ago when i buy it.
It's an FTM64GX25H with DEBX in the serial.

Today i've updated to 1819 using a dos pendrive in IDE mode and the process was very fast and with no problem.
All my data were ok and 'ive booted my win 7 x64 in AHCI and then i've set disabledeletenotify to 0.
I've tried to run a session of AS SSD Benchmark and'ive noticed an high drop of performance in the 4k write test from 7 Mb/s with the 1517 to 4,5 Mb/s with 1819 and the Access was doubled!

It's normal with this FW?
How i can refresh the performance if it's not the FW?
I can use the 1517 PRT or the 1711?

I've done a backup before the update so now i'm reinstalling win 7 x64 with a fast format performed by the w7 install disk to see if i get the original performances. Is this correct?


May you use HDDERASE 4.0 before to install 7.
When all is done, try a bench again.

I've just test again with atto and today i got a low write no same as yesterday :x
I'll do an hdderase again and check ti again.
SSD SuperTalent FTM28GX25H 128Go ME
khalis
 
Posts: 15
Joined: Sat May 30, 2009 1:25 am

Re: Firmware V1819

Postby Johnny Ego » Mon Oct 19, 2009 8:05 am

khalis wrote:May you use HDDERASE 4.0 before to install 7.
When all is done, try a bench again.

I've just test again with atto and today i got a low write no same as yesterday :x
I'll do an hdderase again and check ti again.


i'v hdderase got me some problems...
i've deleted the partitions from w7 x64 disk, recreate them and formatted always from the install, then i've recovered the backup.

Bench are now giving good stats!
the sequential write now is 190 from the 175 of the 1517, all the other are a little better!
Access time is now normal. I think that using the 1517 PRT it's no good.
DisbaleDeleteNotify is 0 so i think that now when i normally delete some files w7 perform a trim...
or this fw has the GC?

Nobody has a changelog?
This FW has Auto-TRIM of W7 or the GC?
Johnny Ego
 
Posts: 2
Joined: Mon Oct 19, 2009 3:45 am

PreviousNext

Return to Firmware

Who is online

Users browsing this forum: No registered users and 1 guest

cron