Page 5 of 13

Re: Firmware V1819

PostPosted: Fri Oct 16, 2009 3:09 pm
by STT-MJ
tody wrote:Hallo,
also ich habe nun auf die V1819 geupdatet.
Updatevorgang ging auch problemlos durch. resettet Bios erkante die SSD und wollte nun W7 installieren...
Leider kann ich nun auf der SSD nichts mehr schreiben.
also die uralt HD aus dem Schrank installation und die SSD angeschlossen. W7 erkennt sie in der Systemverwaltung kann aber nicht auf Sie zugreifen.

Wie bekomme ich das wieder hin ?

Hat jemand einen vorschlag

Hi tody:

Did you flash it back to V1571 before update to V1819? Check the bios setting, also, please record the message you get while you attempt to install w7.

Re: Firmware V1819

PostPosted: Fri Oct 16, 2009 3:10 pm
by STT-MJ
nirolf wrote:I have the a FTM32GX25H - ABIX SSD with firmware 1275. Can I go directly to 1819?

To be honestly, i did not try it, when we release V1571, some ppl upgrade it from V1275 without any problem.
I don't have V1275 drive with me, if you find any problem to flash it directly from V1275 to V1819, PM me and I will email you the old version.

Re: Firmware V1819

PostPosted: Fri Oct 16, 2009 6:44 pm
by aerts
For all the people getting the "Drive not found -- BANANA" stuff, make sure you have AHCI turned off, IDE Mode set to "Legacy", SMART turned off, and so on BACK TO BASICS.
Then it "should work"

Re: Firmware V1819

PostPosted: Fri Oct 16, 2009 7:58 pm
by papontux
ST-J wrote:
You don't have to downgrade to V1571!


EVERY SSD WITH V1711 HAS TO FLASH BACK TO V1571



Hello ST-J,

I have downgraded my FTM64GX25H, S/N xxx-DEBX-xxx shipped with 1711 to 1571.

Upgrade to 1819 fails with

[Error] Vendor information fail
[Error] Firmware customer type read fail
Invalid SSD!


Any clue, what causes this error.

Re: Firmware V1819

PostPosted: Sat Oct 17, 2009 12:39 am
by prinzartus
aerts wrote:For all the people getting the "Drive not found -- BANANA" stuff, make sure you have AHCI turned off, IDE Mode set to "Legacy", SMART turned off, and so on BACK TO BASICS.
Then it "should work"


I know that and did that -> BANANA issue

Re: Firmware V1819

PostPosted: Sat Oct 17, 2009 2:07 am
by thor674
ST-J wrote:
You don't have to downgrade to V1571!


EVERY SSD WITH V1711 HAS TO FLASH BACK TO V1571

hi Thomas:

Thank you for your information, but I have to edit it. V1817 won't be able to flash directly from V1711, because it will work once, but it will also cause serious issues.

TO ALL THE STT ULTRA DRIVE SSD USERS: PLEASE MAKE SURE THE FIRMWARE YOU HAVE IS V1571 OR BELOW BEFORE FLASH TO V1819.


Hi ST-J,

is it really necessary in all cases to go back to V1571 first? Since I directly upgrade from V1711 to V1819 I 've no problems with MAC OS (sleepmode under V1711) or Windows Vista in VM (Parallels Desktop). What are the serious issues exactly?

Is there a chance to downgrade from V1819 to V1571 at all (especially for MAC-users)? And for all other STT Ultra Drive SSD Users with MAC OS: Have you found a way to downgrade from V1711 to V1571 without having Windows OS or only one drive (or only one S-ATA/IDE-connection on board)-> notebook??

Regards Thomas

Re: Firmware V1819

PostPosted: Sat Oct 17, 2009 5:39 am
by PTK
I think ST needs to make a DOS/bootdisk usable 1711->1571 downgrade program.

Was starting the downgrade upgrade system when i realized that the downgrade program ONLY worked in XP and when the SSD isnt a boot disk.

So how exactly you expect me to downgrade when i have 2 64GB SSDs in RAID as Win7 BOOT OS disk ? First delete the raid, install win7 to the SSD1, downgrade ssd2, then install win7 to ssd2, downgrade ssd1, then upgrade them both, remake the raid and finally install win7 for the third time ? Does that downgrade program even work in 64bit windows 7 ?

And reading about the ppls problems with flash errors, one of those flashes most likely will fail and i cant rebuild my win7 install anymore.

This bootdisk downgrade system would help the MAC ppl too, so please make one and make it FAST. :roll:

Re: Firmware V1819

PostPosted: Sat Oct 17, 2009 7:06 am
by kirillsel
aerts wrote:For all the people getting the "Drive not found -- BANANA" stuff, make sure you have AHCI turned off, IDE Mode set to "Legacy", SMART turned off, and so on BACK TO BASICS.
Then it "should work"


How can I do it on a Mac?

Re: Firmware V1819

PostPosted: Sat Oct 17, 2009 8:50 am
by thor674
kirillsel wrote:
aerts wrote:For all the people getting the "Drive not found -- BANANA" stuff, make sure you have AHCI turned off, IDE Mode set to "Legacy", SMART turned off, and so on BACK TO BASICS.
Then it "should work"


How can I do it on a Mac?


Schau mal in deine Inbox. Ich habe dir eine PM geschickt.

For all with problems with STT-ISO-File: You can create your own working ISO: http://supertalent.com/home/forum/viewtopic.php?f=33&t=1579&start=20#p3301 or send me a PM with your email-adress and your serialnumber. I'll make it (if there are not too much enquires ;) ).

Eat more bananas! :lol:

Regards Thomas

Re: Firmware V1819

PostPosted: Sat Oct 17, 2009 10:47 am
by prinzartus
Thanks "thor674" for helping me out with your working image!

Update went fine, no data loss detected. Looking good... so far. ST should revise their boot-cd image, although I really appreciate that ST is providing a complete boot-cd image at all.

Other companies might just provide the flash utility itself, which in my eyes is not aceptable nowadays any longer. My issue has been resolved by the help of "thor674".